In theory, exchanging mainboard on Macbook has no impact because all your data is stored on your harddisk that is untouched. In real life, there are few minor surprises.

First, your MAC address of the network card had changed. This is something you will not notice, unless Murphy's law plays funny game with you, as it did with me. When arriving back to the office, I was able to connect to WiFi network, but the ethernet was stubbornly getting the "internal IP" - 169.254.x.x address, which is pretty much useless from connectivity point of view. We are running two separate networks - both NAT-ed, one on WiFi - mainly for guests, other internal. Not getting an IP address did not make any sense: the cable was OK, because other machine worked just fine with same drop/cable. The Ethernet connection was OK, because it worked when assigned IP address manually.

The problem was - new MAC address. During last week or so, by playing with virtual machines, I must have allocated all available IP addresses from DHCP server space. The leases are fairly long lived and all slots were taken by either computers around the office or by both running and also now defunct VM's. One of them was still kept reserved for my old and gone MBP's MAC address. Nobody would notice the problem, unless you tried to attach new DHCP based VM or new computer. Lesson learned - if you have problems with internal IP address does not want to go away - check the DHCP server. In home environment, resetting the router mostly helps.

Second effect of changed MAC address was that all VMs in Fusion started to ask whether they were moved or copied. Always answer "moved", otherwise you VM will get new virtual MAC address generated - which can have impact on your DHCP space (if in bridged mode).

Third, quite unexpected effect was that Time Machine stopped working, with 'volume cannot be found' message. See e.g. for more details. It looks like Time Machine is using the MAC address to match the backup volume with the computer it belongs to. Clean solution is to erase backup and start from scratch - or use different disk. Partial solution is a hack - in /Volumes/Time Machine Backup/ locate file that has the MAC address encoded in the name, e.g:


Get the new MAC address (from ifconfig) and copy the old cookie file to new cookie file - using the new MAC as name. This made the volume accessible again - with unfortunate effect that pretty much ALL content was considered as unbacked-up and first back up took away over 90 GB of disk space. But at least, the old data was still there, should the need ever occur.

Maybe this experience will be useful for somebody else - it was quite good learning experience for me.